Monday, February 25, 2008

Maplin, Landisk, ViperNas, Password Protected Storage in Vista

I decided to get a Maplin Landisk NAS server on the cheap last week and have had gripes with it and Vista. As I only spent £30 quid on it I wasn't too bothered about taking it back. This device is based on the RDC2882 chipset, which is common to a lot of budget NAS, so they often use the same firmware. Disclaimer - I can't be certain about this last point, so be careful!

Here are my workarounds and fixes.

Problem 1: The firmware doesn't support Vista or has bugs
Solution: Get the firmware here or here in that order.

Problem 2: The updated firmware admin interface looks shoddy or is wrongly branded.
Solution: Get a much improved admin ui interface at Viperfang Networks. (See the Projects link -> ViperNAS). Once you've downloaded the build (currently 1.5b) this can be uploaded to the landisk in exactly the same way as you updated the firmware.

Problem 3: Password protected storage doesn't work in Vista.
Solution: Yes it does (if you have V48 firmware or greater). Use the username "storage\admin" and the password you set on the network share (as per screenshot on this post). Note when you first enter these details it may fail. Just click "ok" a second time on the same dialog after it has failed and it miraculously works!

Problem 4: Samba (network share) performance is abysmal, or it is very laggy.
UPDATED!!! See here!
Solution (partial - anything better?)

Use the FTP service for large network transfers instead. On Vista add a new network location from within the My Computer window - but add the FTP address instead of the share address (e.g. ftp://storage/..... or whatever you set up on the NAS). FTP seems to work flawlessly (but unfortunately you can't run a program across a network like you could with a network share). You can probably do this on XP too if you have the same problem.

Disable differential compression (helps improve speed) and get Windows Vista SP1 (when it is released officially)

Get the most up-to date firmware, see Problem 1.